Задать вопрос

У скольких натуральных чисел от 1 до 2 в степени 10 сумма цифр кратна четырем?

+1
Ответы (1)
  1. 5 августа, 02:36
    0
    var ans, tmp, sum, i:integer; / / объявляем переменные: ответ, временную переменную, сумму и итератор

    begin

    ans:=0; / /сначала ответ равен нулю

    for i:=1 to 2*2*2*2*2*2*2*2*2*2 do / /от единицы до двойки в десятой степени проверяем все числа

    begin

    sum:=0; / /сумма цифр каждого числа изначально нулевая

    tmp:=i; / / записываем число во временную переменную

    while (tmp 0) do / / пока не сложили все цифры в ней

    begin

    sum: = sum + tmp mod 10; / / записываем остаток от ее деления на 10 к сумме

    tmp: = tmp div 10; / /делим нацело на 10

    end;

    if (sum mod 4 = 0) then ans:=ans + 1; / / если сумма кратна четырем, то увеличиваем ответ

    end;

    writeln (ans); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «У скольких натуральных чисел от 1 до 2 в степени 10 сумма цифр кратна четырем? ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
У скольких натуральных чисел от 1 до 2 в степени N, где N = 10, сумма цифр кратна четырем? Комментарий. Например, для N=3N=3 рассматриваются такие числа: 1, 2, 3, 4, ..., 8. Сумма цифр кратна четырем у двух из них.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1) Составить программу нахождения суммы квадратов чисел от 25 до 125. 2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма четных цифр и сумма нечетных цифр заданного числа. 2.
Ответы (1)
Напишите программу на паскале Дано трехзначное число. Определить кратна ли сумма его цифр числу а. Пример работы программы: Входные данные Выходные данные 633 No 4 540 Yes 2
Ответы (1)