Задать вопрос

А) Напишите процедуру, которая при заданных a, b выводит среднее число (используя при этом глобальные переменные) б) Дается буква или символ. Напишите программу определяющая буква это или символ

+5
Ответы (1)
  1. 21 ноября, 20:47
    0
    program zz1;

    var a, b:integer; n:real; //задаем глобальные переменные

    ch:char;

    procedure sr (a, b:integer; var n:real);

    begin

    n: = (a+b) / 2;

    end;

    begin

    //a)

    write ('введите первое число '); / /вводим первое число

    readln (a);

    write ('введите второе число '); / /вводим второе число

    readln (b);

    sr (a, b, n); / /вызываем процедуру

    writeln ('среднее двух чисел = ', n); / /выводим ответ

    //b)

    writeln ('введите символ'); / /вводим любой символ

    read (ch);

    if ((ord (ch) >=65) and (ord (ch) <=90)) or / /проверяем на большую латинскую букву

    ((ord (ch) >=97) and (ord (ch) <=122)) / /проверяем на малую латинскую букву

    then write ('это буква') else write ('это символ'); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «А) Напишите процедуру, которая при заданных a, b выводит среднее число (используя при этом глобальные переменные) б) Дается буква или ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Pascal ABC. Написать процедуру, которая выводит на экран первые 3 элемента из массива, которые не равны друг другу. Или процедуру нахождения 3 максимальных элементов массива, которые не равны друг другу
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
1) Напишите линейную программу, в результате выполнения которой целочисленные переменные x и y обменяются значениями. При этом нельзя использовать дополнительные переменные.
Ответы (1)
Напишите линейную программу, в результате выполнения которой целочисленные переменные x и y обмениваются значениями. При этом нельзя использовать дополнительные переменные.
Ответы (1)