Задать вопрос

Паскаль Напишите программу, которая 10 раз запрашивает ввод целого числа. При завершении ввода на экран выводится сумма чисел, минимальное число, максимальное число.

+3
Ответы (1)
  1. 20 июля, 21:46
    0
    program chisla;

    var

    A:array [1 ... 10] of integer;

    i, min, max, sum:integer;

    begin

    sum:=0;

    for i:=1 to 10 do

    begin

    writeln ('введите число');

    readln (A[i]);

    sum:=sum+A[i];

    end;

    min:=A[1];

    max:=A[1];

    for i:=1 to 10 do

    begin

    if A[i]>max then max:=A[i];

    if A[i]
    end;

    writeln ('сумма введенных чисел = ', sum);

    writeln ('минимальный элемент = ', min);

    writeln ('максимальный элемент = ', max);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Паскаль Напишите программу, которая 10 раз запрашивает ввод целого числа. При завершении ввода на экран выводится сумма чисел, минимальное ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить алгоритм сложения двух целых чисел F и Q, вводимых с клавиатуры. Результат сложения записать в виде переменной W. По данному алгоритму написать программу в Паскале. алг сложение цел F, Q, W нач ввод F ввод Q W:=F+Q вывод W кон 2.
Ответы (1)
Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. В конце работы программы на экран выводится минимальное и максимальное из введенных чисел (не считая 0)
Ответы (1)
Написать программу, которая запрашивает ввод вещественного числа в переменную С, умножает это число на, 2 и выводит результат на экран. Проверить правильность работы программы на числах 2.5,-7.3,0,782.234
Ответы (1)
Определить максимальное значение среди чисел x и y, минимальное значение среди чисел a и b. Числа x и y, a и b вводятся с клавиатуры. Результат работы программы выводится на экран
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)