Задать вопрос
26 июля, 20:37

даны натуральное число n, действительные числа а1, ..., аn. В последовательности а1, ..., аn все отрицательные члены увеличить на 0,5 а все неотрицательные заменить на 0,1.

+4
Ответы (1)
  1. 27 июля, 00:17
    0
    program zz1;

    const n = 5; / / задаем количество элементов в массиве

    var i:integer; / / задаем переменные целого типа

    a:array [1 ... n] of real;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    a[i]:=random (51) - 25+random;

    for i:=1 to n do / / выводим исходный массив на экран в строку в формате восемь знаков для числа и два знака после запятой

    write (a[i]:8:2);

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if a[i] < 0 then a[i]:=a[i] + 0.5 else a[i]:=0.1;

    for i:=1 to n do / / выводим полученный массив на экран в строку в формате восемь знаков для числа и два знака после запятой

    write (a[i]:8:2);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «даны натуральное число n, действительные числа а1, ..., аn. В последовательности а1, ..., аn все отрицательные члены увеличить на 0,5 а все ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить программу в паскале, в которой: а) неотрицательные числа заменить sqr, а отрицательные заменить числом 12345. б) Подсчитать и вывести отрицательные элементы массива
Ответы (1)
Даны действительные числа x, y, z Если все числа положительны, увеличить их значения в 2 раза; во всех отальных случаях отрицательные числа заменить их модулями, а положительные оставить без изменения. (Надо написать программу на паскале)
Ответы (1)
Написать программу в Pascal даны целые числа а1 ... аn. Если в данной последовательности ни одно четное число не расположено после нечетного. то получить все отрицательные члены последовательности иначе-положительное.
Ответы (1)
Даны действительные числа а, b, с. Удвоить эти числа, если а ≥ b ≥ с, и заменить их абсолютными значениями, если это не так.
Ответы (1)
Даны действительные числа a и b если а
Ответы (1)