Задать вопрос

Дан массив с. Найти сколько элементов в массиве меньше своих левых соседей.

+2
Ответы (1)
  1. 11 июля, 04:44
    0
    program zz1;

    const n = 14; / /задаем количество элементов в массиве

    var i, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / записываем в массив числа случайным образом

    m[i]:=random (201) - 60;

    for i:=1 to n do / /выводим массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=2 to n do / / организуем цикл, в котором переберем все числа массива

    if (m[i] < m[i - 1]) then k:=k+1;

    writeln; / / переходим на новую строку для вывода ответа

    write (' количество таких элементов = ', k); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив с. Найти сколько элементов в массиве меньше своих левых соседей. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
Решите одно из предложенных, умоляю дан массив А5 найти сумму и количество положительных элементов дан массив А5 определить количество отрицательных элементов дан массив А6 определить количество положительных элементов
Ответы (1)
1. Дан двумерный массив. Найти сумму элементов этого массива. 2. В одномерном массиве сосчитать количество элементов равных 0 3. Дан двумерный массив. Найти произведение элементов каждого столбца.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного.
Ответы (1)