Задать вопрос

Дан массив из N целых чисел а1, а2, ..., an. Проверить, есть ли в этом массиве три числа, сумма которых равна нулю.

+5
Ответы (1)
  1. 23 июня, 07:34
    0
    program zz1;

    var mas:array[1 ... 20] of integer;

    i, k, n, j, p1, p2, p3, p:integer;

    begin

    read (n); / /вводим количество элементов в массиве

    for i:=1 to n do

    mas[i]:=random (21) - 10; / /записываем числа в массив рандомно от - 10 до 10

    for i:=1 to n do

    write (mas[i],' '); / /выводим числа из массива на экран

    writeln;

    for i:=1 to n-2 do / /запускаем три цикла для перебора чисел массива по три

    for j:=i+1 to n-1 do

    for k:=j+1 to n do

    if mas[i]+mas[j]+mas[k]=0 then begin p:=1; p1:=i; p2:=j; p3:=k; end; / /проверяем, если три числа из массива в сумме дают ноль, то останавливаем циклы и запоминаем их номера

    writeln; / /переходим на новую строку для ответа

    if p=1 then write ('в массиве есть три числа, сумма которых равна нулю. Это', mas[p1],' ', mas[p2],' ', mas[p3])

    else write ('в массиве таких чисел нет'); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив из N целых чисел а1, а2, ..., an. Проверить, есть ли в этом массиве три числа, сумма которых равна нулю. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного.
Ответы (1)
Дан массив, состоящий из 100 целых чисел: а) Вывести все числа, которые встречаются в этом массиве по нескольку раз; б) Вывести все числа, которые встречаются в массиве только по одному разу.
Ответы (1)
1. В массиве из 70 целых чисел найти количество элементов, кратных 3 2. Проверить, что в массиве ровно 3 одинаковых максимальных числа 3. В массиве удалить все элементы, имеющие нечетные значения
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)