Задать вопрос

Дан массив, состоящий из 100 целых чисел: а) Вывести все числа, которые встречаются в этом массиве по нескольку раз; б) Вывести все числа, которые встречаются в массиве только по одному разу.

+3
Ответы (1)
  1. 10 августа, 01:52
    0
    program zz1;

    const n = 15; / / задаем количество элементов в массиве

    var i, k, j:integer; / / задаем переменные целого типа

    m, v:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (21);

    for i:=1 to n do / / выводим массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    writeln (' встречаются один раз: ');

    for i:=1 to n do

    begin

    for j:=1 to n do

    if m[j] = m[i] then k:=k + 1;

    if k=1 then write (m[i], ' ');

    k:=0;

    end;

    writeln;

    writeln (' встречаются несколько раз: ');

    for i:=1 to n do

    begin

    for j:=1 to n do

    if m[j] = m[i] then k:=k + 1;

    if k>1 then write (m[i], ' ');

    k:=0;

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив, состоящий из 100 целых чисел: а) Вывести все числа, которые встречаются в этом массиве по нескольку раз; б) Вывести все числа, ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Вводится массив, состоящий из целых чисел. Найти наибольшее среди них. Входные данные Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Массив состоит из целых чисел.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером). Входные данные Сначала задано число N - количество элементов в массиве (1N10000).
Ответы (1)