Задать вопрос

Написать программу. Даны 2 числа a и b. Найти среднее арифметическое всех чисел кратных 3 из интервала [a, b].

+3
Ответы (1)
  1. 14 января, 21:40
    0
    program zz1;

    var a, b, r, i, k:integer; / / задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (b);

    for i:=a to b do / / организуем цикл, в котором переберем все числа от а до b

    if i mod 3 = 0 then begin r:=r + i; k:=k+1; end; / / вычисляем сумму чисел от а до b кратных трем и их количество

    write (' среднее арифметическое чисел кратных трем от ', a,' до ', b,' = ', r/k); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу. Даны 2 числа a и b. Найти среднее арифметическое всех чисел кратных 3 из интервала [a, b]. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)
Дан массив из 15 чисел заполненный случайными числами из интервала [-20; 20]. определить, что больше среднее арифметическое элементов стоящих на четных местах или среднее арифметическое положительных элементов массива
Ответы (1)
Даны действительные числа a, b. Вывести на экран сообщение "Числа лежат в заданном промежутке", если они принадлежат интервалу (x0, x1] и "Числа вне интервала" в противном случае (приделы интервала x0 и x1 вводятся с клавиатуры)
Ответы (1)
1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего - в куб и нахождения среднего арифметического полученных значений. 2.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)