Задать вопрос
2 августа, 20:30

Даны два действительных положительных числа X и Y. Арифметические действия над числами пронумерованы (1-сложение, 2-вычитание, 3-умножение, 4-деление). Составить программу, которая по введенному номеру выполняет то или иное действие над числами

+2
Ответы (1)
  1. 3 августа, 00:14
    0
    program calc;

    var X, Y:real;

    k:integer;

    begin

    write ('Введите два числа через пробел ');

    readln (X, Y);

    writeln ('Введите номер операции: 1 - "+", 2 - "-", 3 - "x", 4 - "/"');

    readln (k);

    case k of

    1: writeln (X, ' + ', Y, ' = ', X + Y);

    2: writeln (X, ' - ', Y, ' = ', X - Y);

    3: writeln (X, ' * ', Y, ' = ', X * Y);

    4: if Y0 then writeln (X, ' / ', Y, ' = ', X / Y) else writeln ('Деление на 0 недопустимо');

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны два действительных положительных числа X и Y. Арифметические действия над числами пронумерованы (1-сложение, 2-вычитание, 3-умножение, ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы