Задать вопрос

найти периметр пятиугольника по известным координатам его вершин, используя процедуру вычисления длины отрезка по известным координатам его концов

+1
Ответы (1)
  1. 14 июля, 22:59
    0
    program zz1;

    const x1 = 2; / / задаем координаты вершин пятиугольника

    y1 = 2;

    x2 = 12;

    y2 = 12;

    x3 = 20;

    y3 = 20;

    x4 = 26;

    y4 = 2;

    x5 = 21;

    y5 = 12;

    var p, st1, st2, st3, st4, st5:real;

    procedure dl (a, b, c, d:real; var g:real);

    begin

    g:=sqrt (sqr (a - c) + sqr (b - d)); / / вычисляем длину стороны по формуле

    end;

    begin

    dl (x1, y1, x2, y2, st1);

    dl (x3, y3, x2, y2, st2);

    dl (x3, y3, x4, y4, st3);

    dl (x5, y5, x4, y4, st4);

    dl (x1, y1, x5, y5, st5);

    p:=st1 + st2 + st3 + st4 + st5;

    write (' периметр пятиугольника = ', p); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «найти периметр пятиугольника по известным координатам его вершин, используя процедуру вычисления длины отрезка по известным координатам его ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1 Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров, в каком из двух введенных с клавиатуры целых чисел произведение цифр больше.
Ответы (1)
Pascal ABC. Написать процедуру, которая выводит на экран первые 3 элемента из массива, которые не равны друг другу. Или процедуру нахождения 3 максимальных элементов массива, которые не равны друг другу
Ответы (1)
Составить программу для вычисления площади треугольника с координатами вершин (x1, y1), (x2, y2), (x3, y3), используя формулу для вычисления расстояния между двумя точками на плоскости. Площадь вычисляется по формуле Герона
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
С. Р. О. Ч. Н. О. Составить процедуру, вичисляющую значение TRUE, если в первом из двух заданных одномерных массивов количество отрицательных элементов окажется больше, чем во втором, и значение FALSE в противном случае.
Ответы (1)