Задать вопрос

Дан массив из N целых чисел. Написать программу, определяющую, максимальный элемент массива и его номер.

+5
Ответы (1)
  1. 28 ноября, 08:25
    0
    Сначала в разделе описания переменных описываем все переменные, которые будут использованы в программе, а именно N - количество элементов массива, I - переменная счетчик, max - максимальный элемент массива, k - индекс этого максимального элемента. Далее вводим N с клавиатуры и вводим элементы массива. Сначала залем индекс элемента 1, то есть k=1, а максимальный элемент предполагаем равен первому элементу массива, далее нужно пробежать по всем элементам массива и сравнить их с максимальным, если какой-то элемент больше max, то тогда переменной max присваивается его значение и все остальные элементы сравниваются с ним.

    program primer;

    var N, i, max, k: integer;

    x=array [1 ... N] of integer;

    begin

    read (N);

    for i:=1 to N do

    begin

    readln (a[i]);

    end;

    k:=1;

    max:=A[1];

    for i:=2 to N do

    if max
    begin

    max:=a[i];

    k:=i

    end;

    write ('Маx=', max);

    write ('INDEX=', k);

    end;

    END.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив из N целых чисел. Написать программу, определяющую, максимальный элемент массива и его номер. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)
Дан одномерный массив A[N]. Удвоить минимальный элемент массива и уменьшить в два раза максимальный элемент массива
Ответы (1)