Задать вопрос
13 января, 19:51

Составить программу на суммирование элементов массива. Произвести ввод и отладку программы, проанализировать полученный результат.

+3
Ответы (1)
  1. 13 января, 22:18
    0
    Программа на С++:

    #include

    using namespace std;

    int main ()

    {

    setlocale (LC_ALL, "Russian");

    int n;

    int Sum = 0;

    cout << "Введите количество элементов в массиве." << endl;

    cin >> n;

    int a[n];

    for (int i = 0; i < n; i++) {

    cout << "Введите элемент массива под номером: " << i + 1 << endl;

    cin >> a[i];

    Sum = Sum + a[i];

    }

    cout << "Сумма элементов массива равна: " << Sum << "." << endl;

    return 0;

    }

    Проанализировать работу программы можно на простых тестах:

    1. Входные данные: 4 1 2 3 4. Результат: 10.

    2. Входные данные: 3 - 4 5 1. Результат: 2.

    3. Входные данные: 2 - 100 100. Результат: 0.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу на суммирование элементов массива. Произвести ввод и отладку программы, проанализировать полученный результат. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить алгоритм сложения двух целых чисел F и Q, вводимых с клавиатуры. Результат сложения записать в виде переменной W. По данному алгоритму написать программу в Паскале. алг сложение цел F, Q, W нач ввод F ввод Q W:=F+Q вывод W кон 2.
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями. 2. Составить программу ввода элементов массива A[1 ...
Ответы (1)
Дан целочисленный массив из 2000 элементов. Если сумма всех элементов массива чётная, нужно вывести количество нечётных (по значению) элементов массива, если нечётная - количество чётных.
Ответы (1)