Задать вопрос

написать программу в Паскале: Даны три числа А, В, С. Определить являются ли они последовательными членами арифметической прогрессии. Найти их разность.

+1
Ответы (1)
  1. 5 августа, 03:56
    0
    program zz1;

    var a, b, c:integer; / /задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (b);

    write (' введите третье число '); / / вводим с клавиатуры третье число

    read (c);

    if (a-b) = (b-c) then writeln (' являются последовательными членами арифметической прогрессии ') / / выводим ответ

    else writeln (' не являются последовательными членами арифметической прогрессии');

    write (' разность трех заданных чисел = ', a - b - c);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «написать программу в Паскале: Даны три числа А, В, С. Определить являются ли они последовательными членами арифметической прогрессии. Найти ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)
1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего - в куб и нахождения среднего арифметического полученных значений. 2.
Ответы (1)
C++Напишите программу, которая заполняет массив из N элементов членами арифметической прогрессии с начальным значением X и разностью D.
Ответы (1)
Даны действительные числа x, y, z Если все числа положительны, увеличить их значения в 2 раза; во всех отальных случаях отрицательные числа заменить их модулями, а положительные оставить без изменения. (Надо написать программу на паскале)
Ответы (1)
Даны два числа. Найти меньшее из них. (написать программу на Паскале)
Ответы (1)