Задать вопрос

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу. (pascal)

+1
Ответы (1)
  1. 3 сентября, 23:24
    0
    var i, s, a, b, c, ch, o:integer;

    begin

    o:=0;

    writeln (' Vvedite chislo ');

    readln (ch);

    for i:=100 to 999 do

    begin

    a:=i div 100;

    b: = (i div 10) mod 10;

    c:=i mod 10;

    if ((a+b+c) = ch) then

    begin

    inc (o);

    writeln (i);

    end;

    end;

    if o = 0 then writeln ('error!');

    readln;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найдите все трехзначные числа, сумма цифр которых равна данному целому числу. (pascal) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма четных цифр и сумма нечетных цифр заданного числа. 2.
Ответы (1)
Найти все целые трехзначные числа, которые меньше заданного числа. (Pascal)
Ответы (1)
Напишите программу в паскаль! Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в K - ю степень (где K - количество цифр в числе) равна самому числу. Например, 153 = 1 3 + 5 3 + 3 3.
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма первой и второй цифр и сумма третьей и четвёртой цифр заданного числа. 2.
Ответы (1)