Задать вопрос

Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма первой и второй цифр и сумма третьей и четвёртой цифр заданного числа. 2. Полученные два числа записываются друг за другом в порядке невозрастания (без разделителей). Пример. Исходное число: 2177. Поразрядные суммы: 3, 14. Результат: 143. Определите, сколько из приведённых ниже чисел могут получиться в результате работы автомата. 1915 10 110 1516 1211 316 1519 116 1515 В ответе запишите только количество чисел.

+5
Ответы (1)
  1. 10 апреля, 10:18
    0
    Для вычисления можно составить программу на Pascal:

    var n, n12, n34, i, j, x: integer;

    begin

    for n : = 1000 to 999 do begin

    n12 : = (n div 1000) + (n div 100 mod 10);

    n34 : = (n div 10 mod 10) + (n mod 10);

    i: = 1;

    while (n34 div 10) > 0 do begin

    i : = i + 1;

    n34 : = n34 div 10;

    end;

    for j : = 1 to i do

    n12 : = n12 * 10;

    if n12 + n34 = 1915 then x : = x + 1 else if n12 + n34 = 10 then x : = x + 1 else

    if n12 + n34 = 110 then x : = x + 1 else if n12 + n34 = 1516 then x : = x + 1 else

    if n12 + n34 = 1211 then x : = x + 1 else if n12 + n34 = 316 then x : = x + 1 else

    if n12 + n34 = 1519 then x : = x + 1 else if n12 + n34 = 116 then x : = x + 1 else

    if n12 + n34 = 1515 then x : = x + 1;

    end;

    writeln (x);

    end.

    Ответ (с выхода программы) : 4.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Автомат получает на вход пятизначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма первой, третьей и пятой цифр и сумма второй и четвёртой цифр заданного числа. 2.
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма четных цифр и сумма нечетных цифр заданного числа. 2.
Ответы (1)
Автомат получает на вход трёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1.
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое дестичное число по следующим правилам. 1. Вычисляются два числа - сумма первой и второй цифр и сумма третьей и четвертой цифр заданного числа. 2.
Ответы (1)
Автомат получает на вход пятизначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма первых трёх цифр и сумма последних трёх цифр. 2.
Ответы (1)