Задать вопрос
3 сентября, 15:22

Составьте программу в Паскале. Условный оператор. Ввести число А. Начертить вертикальную линию в левой части экрана если A<0 и в правой части экрана в противном случае. Данные A=-20 (результат в левой части), А=20 (результат в правой части).

+1
Ответы (1)
  1. 3 сентября, 19:19
    0
    uses

    graphabc; / / подключаем графику.

    var

    a : integer; / / объявляем переменную целочисленного типа.

    begin

    writeln ('Введите число:'); / / вывод строки на экран.

    readln (a); / / считываем значение переменной.

    setpenwidth (5); / / устанавливаем ширину линии.

    setpencolor (clRed); / / устанавливаем цвет линии.

    if a < 0 then / / если число отрицательное.

    line (20,100,20,320) / / рисуем линию.

    else / / если число положительное, либо 0.

    line (620,100,620,320); / / рисуем линию.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу в Паскале. Условный оператор. Ввести число А. Начертить вертикальную линию в левой части экрана если A ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Ввести 2 числа используя оператор ввода данных read (). Перед оператором read () обязательно вывести объяснения значения какой переменной надо ввести (Например, writeln ('vvedite a'); ). Ввести их через запятую.
Ответы (1)
Укажите, как выделить следующие фрагменты теста. Отдельное 1. Подвести указатель мыши к левой границе слово строки так, чтобы он принял вид наклонной стрелки. 2. Выполнить щелчок левой кнопкой мыши Строка текста 1.
Ответы (1)
Составить программу с ветвящейся структурой, используя условный оператор if для квадратного уравнения вида ax2+bx+c=0
Ответы (1)
Ввести число от 5 до 9. Вывести его значение словом. Составить программу для решения приведенного ниже задания двумя способами, используя: а) команду выбора case; б) команду if. Ввести число от 5 до 9. Вывести его значение словом.
Ответы (1)
Составить программу вычисления значения функции y = 3x в 6 степени - 6x в 2 степени-7, используя оператор ввода данных b с экрана монитора и вывода y на экран
Ответы (1)