Задать вопрос
18 октября, 09:43

Составить алгоритм и программу решения задачи: Дано 15 вещественных чисел. Определить сколько среди них больше, чем первое число.

+1
Ответы (1)
  1. 18 октября, 10:49
    0
    Все эти 15 чисел заранее будут известны пользователю, а значит нужно написать код, который позволит ему вводить эти числа.

    Создадим переменные для вводимых чисел, для счетчика и для первого числа, поскольку именно с ним нужно будет сравнивать другие 14:

    var number, first_number: real; count: integer;

    Заполняем первое число:

    writeln ('Введите первое число:');

    readln (first_number);

    Заполняем оставшиеся 14 чисел:

    for i:integer:=2 to 15 do

    begin

    writeln ('Введите число ', i,; : ');

    readln (number);

    if number> first_number then

    count:=count + 1;

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить алгоритм и программу решения задачи: Дано 15 вещественных чисел. Определить сколько среди них больше, чем первое число. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Что такое алгоритм? Зачем люди составляют и исполняют алгоритм. Какими разными способами можно описать способ решения задач? Как называют наглядную модель процесса решения задач? Какой алгоритм можно назвать линейным?
Ответы (1)
Написать программу в паскале: Даны целое n>0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. Найти величину наибольшего среди отрицательных чисел этой последовательности.
Ответы (1)
1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего - в куб и нахождения среднего арифметического полученных значений. 2.
Ответы (1)
1 - Задан массив из N вещественных элементов. Заменить каждый элемент, кроме первого, суммой предыдущих элементов. 2 - Задан массив из N вещественных элементов. Найти минимальный из локальных минимумов данного массива.
Ответы (1)
Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического. Протестировать алгоритм на исходных данных: - 5,8,-1,9. Линейный алгоритм
Ответы (1)