Задать вопрос
15 августа, 02:07

Составить программу которая запрашивает 10 чисел и расставляет их порядке возрастания

+4
Ответы (1)
  1. 15 августа, 04:06
    0
    prog rty; / название программы;

    const n = 10; / введем константу;

    var a:array[1 ... n] of integer; / количество целых элементов в массиве;

    c, i:integer;

    begin

    clrscr; randomize; / подключаем процедуру и рандомайзер;

    for i: = 1 to n do / цикл;

    begin

    a[i]: = random (10); / берем рандомные 10 цифр;

    write (a[i]:3) / выводим на экран;

    end; / закрываем цикл;

    writeln;

    for i: = 1 to n - 1 do / цикл в котором мы сравниваем числа;

    for j: = i + 1 to n do

    if a[i] > a[j]

    then begin c: = a[i];

    a[i] = a[j];

    a[j] = c;

    end;

    for i: = 1 to n do / выстраиваем от меньшего к большему;

    write (a[i]:3) / вывод.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу которая запрашивает 10 чисел и расставляет их порядке возрастания ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике