Задать вопрос

составить программу которая запрашивает n целых чисел и вычисляет их среднее арифметическое

+3
Ответы (1)
  1. 22 февраля, 06:02
    0
    program zz1;

    var a, n, i, s:integer; / / задаем переменные целого типа

    sr:real; / / задаем переменную не целого типа

    begin

    write (' введите n '); / / вводим заданное n

    read (n);

    for i:=1 to n do / / организуем цикл на n повторений

    begin

    read (a); / / вводим очередное число с клавиатуры

    s:=s + a; / / находим сумму введенных чисел

    end;

    sr:=s/n;

    writeln (' среднее арифметическое ', n, ' введенных чисел = ', sr:5:2); / / выводим ответ в столбец в формате пять знаков для всего числа и два знака после точки

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «составить программу которая запрашивает n целых чисел и вычисляет их среднее арифметическое ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Напишите программу, которая запрашивает четыре целых числа и выдает на экран: 1) сумму чисел; 2) сумму квадратов чисел; 3) среднее арифметическое чисел; 4) сумму парных произведений.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)
1) Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.2) Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.
Ответы (1)