Задать вопрос
27 марта, 15:13

Вводится последовательность чисел Конец последовательности - 0 найти максимальное число. Паскаль абс

+2
Ответы (1)
  1. 27 марта, 16:56
    0
    program zz1;

    var max, n:integer; / / задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры число

    read (n);

    while n 0 do / / организуем цикла, в котором будем вводить числа последовательности, пока не будет введен ноль

    begin

    if n > max then max:=n; / / проверяем, если введенное число больше максимального, то записываем его в максимальное

    read (n); / / вводим с клавиатуры очередное число последовательности

    end;

    write (' наибольшее число в последовательности = ', max); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вводится последовательность чисел Конец последовательности - 0 найти максимальное число. Паскаль абс ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Вводится последовательность целых чисел, оканчивающаяся нулем. Число 0 в последовательность не входит. Выведите элементы последовательности в обратном порядке. Для хранения данных используйте стек.
Ответы (1)
Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс
Ответы (1)
Вводится последовательность ненулевых чисел, 0 - конец последовательности. Определить наибольшее число в последовательности.
Ответы (1)
Напишите программу в паскале, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
Определите среднее арифметическое элементов последовательности, завершающейся числом 0. Число 0 в последовательность не входит. Числа, следующие за нулем, считывать не нужно. Входные данные Вводится последовательность целых чисел.
Ответы (1)