Задать вопрос

Написать программу, которая для заданного N определяет, сколько нулей стоит в конце числа N!. (Предполагается, что N достаточно велико и непосредственное вычисление функции N! умножением невозможно).

+2
Ответы (1)
  1. 1 октября, 16:50
    0
    Если писать на языке программирования - Python, то код может быть таким:

    print (int (input ()) / / 5)

    Если писать на языке программирования - Pascal, то код может быть таким:

    program 1;

    var n: integer;

    begin

    readln (n);

    n : = n div 5

    writeln (n);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу, которая для заданного N определяет, сколько нулей стоит в конце числа N!. (Предполагается, что N достаточно велико и ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Сколько значащих нулей в двоичной записи десятичного числа 503? 2). Для каждого из перечисленных ниже десятичных чисел построили двоичную запись. Укажите число, двоичная запись которого содержит наибольшее количество значащих нулей.
Ответы (1)
1) Написать программу, которая находит в массиве случайных символов первое вхождение заданного символа.
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
3. Какое из высказываний является истинным: a. Для того чтобы число делилось на 3, достаточно, чтобы его последняя цифра делилась на 3 b. Для того чтобы число делилось на 2, достаточно, чтобы оно было четным c.
Ответы (1)