Задать вопрос

Определите, что будет напечатано в результате работы следующего фрагмента программы: var k, s: integer; begin s:=0; k:=0 while k<30 do begin k:=k+3; s:=s+k; end; write (s); end.

+4
Ответы (1)
  1. 5 июня, 19:17
    0
    Переменная k будет увеличиваться на 3 при каждом выполнении цикла. Всего циклов будет 10, до достижения переменной k значения 30:

    3, 6, 9, ..., 30.

    В переменной s будет накапливаться сумма значений k. Значение s после выполнения десяти циклов будет представлять собой сумму арифметической прогрессии, которую можно посчитать по первому члену a₁ = 3, последнему члену а10 = 30 и числу членов n = 10:

    s = (a₁ + an) n / 2 = ((3 + 30) * 10) / 2 = 165.

    Ответ: будет напечатано число 165.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Определите, что будет напечатано в результате работы следующего фрагмента программы: var k, s: integer; begin s:=0; k:=0 while k ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
6) Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin s : = 0; for n:=4 to 13 do begin s : = s + 15; end; write (s) end.
Ответы (1)
1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1;
Ответы (1)
Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin n : = 1; s : = 0; while n < = 20 do begin s : = s + 33; n : = n + 1 end; write (s) end.
Ответы (1)
Определите, что будет напечатано в результате работы следующего фрагмента программы: var k, s:integer; begin s:=2; k:=2; while k < 50 do begin s:=s+k; k:=k+1; end; write (s); end.
Ответы (1)
Определите, что будет напечатано в результате работы следующего фрагмента программы:var n, s: integer; begin n : = 3; s : = 0; while n < = 26 dobegins : = s + 6; n : = n + 1end; write (s) end.
Ответы (1)