Задать вопрос

Написать программу, в паскале, для нахождения наименьшего и наибольшего из трех чисел с помощью процедур

+5
Ответы (1)
  1. 6 июня, 11:01
    0
    program zz1;

    var a, b, c, s : integer; / / задаем переменные целого типа

    procedure max (n, m, v:integer; var k:integer);

    begin

    if (n>=m) and (n>=v) then k:=n;

    if (m>=n) and (m>=v) then k:=m;

    if (v>=m) and (v>=n) then k:=v;

    end;

    procedure min (n, m, v:integer; var k:integer);

    begin

    if (n<=m) and (n<=v) then k:=n;

    if (m<=n) and (m<=v) then k:=m;

    if (v<=m) and (v<=n) then k:=v;

    end;

    begin

    write (' введите первое число a '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число b '); / / вводим с клавиатуры второе число

    read (b);

    write (' введите третье число b '); / / вводим с клавиатуры третье число

    read (c);

    max (a, b, c, s); / / вызываем процедуру

    write (' максимальное = ', s); / /выводим ответ

    min (a, b, c, s); / / вызываем процедуру

    write (' минимальное = ', s); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу, в паскале, для нахождения наименьшего и наибольшего из трех чисел с помощью процедур ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы