Задать вопрос

Ввести целое число и определить верно ли что все его цифры расположены в порядке возрастания

+2
Ответы (1)
  1. 20 февраля, 00:52
    0
    program zz1;

    var s, n, k, p:integer; / / задаем переменные целого типа

    begin

    write (' введите натуральное число ');

    read (n); / / вводим с клавиатуры число

    k:=n mod 10; / /получаем последнюю цифру

    s:=k; / / запоминаем ее

    n:=n div 10; / /отбрасываем ее

    repeat / / организуем цикл, пока в числе есть цифры

    k:=n mod 10; / /получаем последнюю цифру

    if k > = s then p:=1; / / сравниваем с предыдущей

    s:=k; / / запоминаем ее

    n:=n div 10; / /отбрасываем ее

    until n=0;

    if p = 0 / / проверяем, если не нашлась цифра больше следующей

    then writeln (' Верно ') / / выводим один ответ

    else writeln (' Неверно '); / / иначе, выводим другой ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Ввести целое число и определить верно ли что все его цифры расположены в порядке возрастания ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
Ввести 2 числа используя оператор ввода данных read (). Перед оператором read () обязательно вывести объяснения значения какой переменной надо ввести (Например, writeln ('vvedite a'); ). Ввести их через запятую.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1) дано целое число N (больше 0). Найти сумму 1+1/2+1/3 ... 1/N (вещественное число). Входные данные: ввести целое числоN (1
Ответы (1)
Ввести число от 5 до 9. Вывести его значение словом. Составить программу для решения приведенного ниже задания двумя способами, используя: а) команду выбора case; б) команду if. Ввести число от 5 до 9. Вывести его значение словом.
Ответы (1)