Задать вопрос

Дана последовательность чисел заканчивающихся 0. Найдите произведение этих чисел

+5
Ответы (1)
  1. 5 февраля, 01:22
    0
    program zz1;

    const n = 13; / / задаем количество элементов в последовательности

    R:array [1 ... n] of integer = (60, - 30, 10, - 60, 20, - 30, 20, 90, 40, - 80, 10, - 50, 60); / / задаем последовательность чисел

    var i, k:integer; / / задаем переменные целого типа

    begin

    k:=1; / / задаем начальное значение для произведения

    for i:=1 to n do / / организуем цикл, в котором переберем все элементы последовательности

    k:=k*R[i]; / / умножаем число последовательности на произведение

    write (' произведение чисел последовательности = ', k); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана последовательность чисел заканчивающихся 0. Найдите произведение этих чисел ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу которая вводит последовательность целых чисел заканчивающихся нулём и определяет сколько из этих чисел удовлетворяет условию: сумма значений цифр десятичной записи числа равно 10
Ответы (1)
С клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0. Определить: 1) Количество четных чисел. 2) Сумму чисел, заканчивающихся на 5 и положительных Найти сумму чисел: 5+10+15+20+ ...+n
Ответы (1)
Написать программу в Pascal ABC. Последовательность чисел заканчивающихся на 0 (ноль). Необходимо найти количество чисел у которых количество десятков "4" или "6".
Ответы (1)
Дан двумерный массив размерностью 4 на 5. элементы массива создаются случайным образом. промежуток от - 70 до 100. найти произведение чисел, заканчивающихся на 3 (на языке Паскаль).
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)