Задать вопрос

Массив из 10 элементов заполнен целыми случайными числами от - 10 до 10. Написать программу, определяющую количество чётных элементов

+1
Ответы (1)
  1. 7 января, 18:12
    0
    var

    i, n: integer; / / объявляем переменные целочисленного типа.

    arr: array [1 ... 10] of integer; / / объявляем массив.

    s : string; / / объявляем переменную строкового типа.

    begin

    for i : = 1 to 10 do / / начало цикла.

    begin

    arr[i] : = random (-10, 10); / / заполняем элемент массива числом из диапазона - 10; 10.

    s : = s + inttostr (arr[i]) + ' '; / / записываем массив в одну строку.

    if (arr[i] mod 2 = 0) then n : = n + 1; / / считаем сумму положительных чисел.

    end;

    writeln ('Исходный массив: ', s); / / вывод строки на экран.

    writeln ('Количество четных элементов равно: ', n); / / вывод строки на экран.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Массив из 10 элементов заполнен целыми случайными числами от - 10 до 10. Написать программу, определяющую количество чётных элементов ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)
Составьте программу которая заполняет массив b 1 ... 8 случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов с чётными значениями пример ввода: исходный массив: 10 2 4 1 3 5 7 8 количество пар чётных элементов =
Ответы (1)
1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями. 2. Составить программу ввода элементов массива A[1 ...
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)