Задать вопрос

Напишите программу вычисления наибольшего общего делителя двух натуральных чисел. Используйте оператор repeat, while.

+3
Ответы (1)
  1. Program zz1;

    var M, N: integer; / / задаем переменные целого типа

    begin

    writeln ('Введите М и N'); / / вводим с клавиатуры два заданных числа через пробел

    readln (M, N);

    while M N do / / организуем цикл, пока исходные два числа не равны между собой

    begin

    if M>N / / проверяем условие, если первое число больше второго

    then M:=M-N / / то, от первого отнимаем второе

    else N:=N-M / /иначе, от второго отнимаем первое

    end;

    write ('Н0 Д=', M); / / в связи с тем, что по окончании цикла два числа сравняются, ответом является любое из них

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу вычисления наибольшего общего делителя двух натуральных чисел. Используйте оператор repeat, while. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу для вычисления наибольшего общего делителя двух целых чисел: а) используйте оператор repeat б) используйте оператор while
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального (наибольшего) из введёных чисел. Используйте оператор repeat. Решить в паскале.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Составить алгоритм и программу определения наибольшего общего делителя (НОД) двух натуральных чисел!
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчет количества введеных чисел. Используйте оператор while. Решить в паскале.
Ответы (1)