Задать вопрос

Дано число а. Выяснить является ли оно не кратным 3 или 4. Если - да, то переменной y присвоить значение 1, иначе - 0.

+4
Ответы (1)
  1. 17 февраля, 09:38
    0
    Напишем программу, которая будет переменной y присваивать значение 1 при выполнении определенного условия, иначе будет присваивать 0.

    programm prisvoenie;

    var a, b, y: integer;

    begin

    writeln ('введите любое число с клавиатуры');

    readln (a);

    b: = a mod 3;

    c: = a mod 4;

    if b = 0

    then

    y: = 0;

    witeln ('переменной у присвоено значение ноль');

    else

    y: = 1;

    witeln ('переменной у присвоено значение единицы');

    if с = 0

    then

    y: = 0;

    witeln ('переменной у присвоено значение ноль');

    else

    y: = 1;

    witeln ('переменной у присвоено значение единицы');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано число а. Выяснить является ли оно не кратным 3 или 4. Если - да, то переменной y присвоить значение 1, иначе - 0. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Запишите на алгоритмическом языке алгоритм, в результате которого переменной а будет присвоено значение переменной Ь, переменной b - значение переменной с, а переменной с - значение переменной а. Используйте не более одной промежуточной переменной.
Ответы (1)
Даны три отрезка со сторонами a, b, c. Выяснить можно ли построить треугольник с данными сторонами, если - да, то переменной y присвоить значение 1, иначе - 0.
Ответы (1)
Опишите на изучаемом языке программирования следующую информацию" если значение переменной s больше значения переменной d, то максимуму присвоить значение переменной s
Ответы (1)
Составьте программу обмена значениями двух переменных величин: по следующей схеме: в-присвоить значение с а-присвоить значение в
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)