Задать вопрос

Даны три отрезка со сторонами a, b, c. Выяснить можно ли построить треугольник с данными сторонами, если - да, то переменной y присвоить значение 1, иначе - 0.

+3
Ответы (1)
  1. 10 марта, 09:15
    0
    program zz1;

    var a, b, c, y:integer; / / задаем переменные целого типа

    begin

    write (' введите первую сторону треугольника ');

    read (a);

    write (' введите вторую сторону треугольника ');

    read (b);

    write (' введите третью сторону треугольника ');

    read (c);

    If (a + b > c) and (c + b > a) and (a + c > b) / / проверяем условие существования треугольника с заданными длинами сторон, если треугольник существует, то

    Then y:=1 / / переменной присваиваем 1

    else y:=0; / / иначе, переменной присваиваем 0

    write (' y = ', y);

    END.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны три отрезка со сторонами a, b, c. Выяснить можно ли построить треугольник с данными сторонами, если - да, то переменной y присвоить ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Запишите на алгоритмическом языке алгоритм, в результате которого переменной а будет присвоено значение переменной Ь, переменной b - значение переменной с, а переменной с - значение переменной а. Используйте не более одной промежуточной переменной.
Ответы (1)
Дано число а. Выяснить является ли оно не кратным 3 или 4. Если - да, то переменной y присвоить значение 1, иначе - 0.
Ответы (1)
Опишите на изучаемом языке программирования следующую информацию" если значение переменной s больше значения переменной d, то максимуму присвоить значение переменной s
Ответы (1)
Составьте программу обмена значениями двух переменных величин: по следующей схеме: в-присвоить значение с а-присвоить значение в
Ответы (1)
1. какие команды присваивания составлены правильно? a) A: = В б) А=В в) А=B+1 г) А+1:=А 2. Сколько промежуточных переменных потребуется для того, чтобы переменной А было присвоено значение переменной В, переменной В - значение переменной С, а
Ответы (1)