Задать вопрос
30 апреля, 03:10

Ввести массив A (N). Найти максимальный элемент массива, произведение нечетных элементов массива. Заменить максимум на произведение. Вывести полученный массив и произведение.

+5
Ответы (1)
  1. 30 апреля, 07:03
    0
    program zz1;

    const n = 7; / / задаем количество элементов в массиве

    var i, s, p, k, max1:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (51);

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    max1:=0; p:=1;

    for i:=1 to n do / / находим максимальный элемент и его номер

    if m[i]>max1 then begin max1:=m[i]; k:=i; end;

    for i:=1 to n do / / находим произведение нечетных

    if m[i] mod 2 = 1 then p:=p * m[i];

    m[k]:=p;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    write (' полученное произведение = ', p); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Ввести массив A (N). Найти максимальный элемент массива, произведение нечетных элементов массива. Заменить максимум на произведение. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Дан массив состоящий из n элементов. вывести максимальный элемент массива и его индекс. Если в массиве содержится несколько максимальных элементов, посчитать количество максимальных элементов, вывести максимальное значение и индексы элементов его
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)