Задать вопрос

На Паскале. Вводятся координаты X, Y для N точек. Определите, сколько точек попадают в круг радиуса R. Сколько точек попадают в кольцо с меньшим радиусом R1, большим R2.

+4
Ответы (1)
  1. 14 октября, 15:26
    0
    program zz1;

    var k1, k2, n, i, R, R1, R2, x, y:integer; / / задаем переменные целого типа

    begin

    write (' введите количество точек n '); / / вводим с клавиатуры число

    read (n);

    write (' введите радиус R '); / / вводим с клавиатуры число

    read (R);

    write (' введите радиус R1 '); / / вводим с клавиатуры число

    read (R1);

    write (' введите радиус R2 '); / / вводим с клавиатуры число

    read (R2);

    for i:=1 to n do

    begin

    read (x, y);

    if x*x + y*y < R*R then k1:=k1 + 1;

    if (x*x + y*y R1*R1) then k2:=k2 + 1;

    end;

    writeln (' количество точек внутри круга = ', k1); / / выводим ответ

    writeln (' количество точек внутри кольца = ', k2);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «На Паскале. Вводятся координаты X, Y для N точек. Определите, сколько точек попадают в круг радиуса R. Сколько точек попадают в кольцо с ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Ввести с клавиатуры координаты двух точек а и в на плоскости вещественный числа вычислить длину. программу нужно написать в паскале пример, как должно получиться введите координаты точки а 5.5 3.5 введите координаты точки b 1.5 2 длинна отрезка ab=4.
Ответы (1)
Нарисовать N концентрических окружностей с минимальны радиусом r и максимальным радиусом R c центром с координатами X и Y. N, r, R, X, Y вводятся с клавиатуры. pascal abc
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
1) Как можно описать на Паскале 1) Как можно описать на Паскале массив, в котором будет храниться значения численности населения Москвы к концу каждого года XX века?2) Вы приобрели котёнка. Каждый вечер вы определяете его вес с помощью весов.
Ответы (1)
Написать на Паскале Остаток Входные данные Вводятся 4 числа: a, b, c и d. Выходные данные Выведите все числа на отрезке от a до b, дающие остаток c при делении на d. Если таких чисел не существует, то ничего выводить не нужно.
Ответы (1)