Задать вопрос

Нарисовать N концентрических окружностей с минимальны радиусом r и максимальным радиусом R c центром с координатами X и Y. N, r, R, X, Y вводятся с клавиатуры. pascal abc

+1
Ответы (1)
  1. 21 ноября, 13:29
    0
    Решение. Введем следующие обозначения: N - количество окружностей; X, Y - координаты центра окружностей; max - максимальный радиус; min - минимальный радиус; i - параметр, который будет принимать значения радиусов от max до min. Тогда программа на языке программирования Pascal ABC может выглядеть так:

    Program zadacha;

    Uses crt, graphABC;

    var i, X, Y, max, min, N:integer;

    begin

    clrscr;

    write ('Vvedite kolichestvo okrugnostej N:');

    readln (N);

    write ('Vedite koordinatu X:');

    readln (X);

    write ('Vedite koordinatu Y:');

    readln (Y);

    write ('Vedite radius max:');

    readln (max);

    write ('Vedite radius min:');

    readln (min);

    SetWindowSize (800,600);

    for i:=max downto min do

    begin

    if n=0 then break;

    if (n=1) then circle (X, Y, min) else

    circle (X, Y, i);

    i:=i-5;

    n:=n-1;

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Нарисовать N концентрических окружностей с минимальны радиусом r и максимальным радиусом R c центром с координатами X и Y. N, r, R, X, Y ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Закончите предложения. 1) Чтобы выбрать фоновый цвет, необходимо. 2) Чтобы выбрать основной цвет, необходимо. 3) Чтобы нарисовать прямоугольник, необходимо. 4) Чтобы нарисовать квадрат, необходимо. 5) Чтобы нарисовать овал, необходимо.
Ответы (2)
Нужно написать прогу в Pascal ABC. В заданном тексте заменить все слова A1 на слова A2 (слова в тексте разделены пробелами слова A1 и A2 вводятся с клавиатуры)
Ответы (1)
Напишите программу, которая находит сумму элементов массива (25 целых чисел, которые вводятся с клавиатуры), и выводит на экран среднее значение его элементов. программа: Pascal ABC.
Ответы (1)
Нарисовать снеговика. Количество кругов задаётся c клавиатуры. Pascal ABC
Ответы (1)