Задать вопрос

Дана последовательность натуральных чисел, окончанием последовательности число 0. составить программу, котрая вычисляет сумму и среднее арифмитическое чисел кратных 3

+5
Ответы (1)
  1. 2 июня, 17:39
    0
    program zz1;

    var i, k, n, k1:integer; / / задаем переменные целого типа

    m:array [1 ... 10000] of integer;

    begin

    read (m[1]); i:=1;

    while m[i]0 do / / вводим числа последовательности с клавиатуры до тех пор, пока не введем ноль, записываем их в массив

    begin

    i:=i+1;

    read (m[i]);

    end;

    n:=i;

    for i:=1 to n do / / организуем цикл, в котором переберем все числа последовательности

    if (m[i] mod 3 = 0) and (m[i]0) then begin k1:=k1 + m[i]; k:=k+1; end; / / получаем сумму положительных чисел

    writeln (' среднее арифметическое чисел последовательности кратных трем = ', k1/k:5:2);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана последовательность натуральных чисел, окончанием последовательности число 0. составить программу, котрая вычисляет сумму и среднее ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)
Составить программу которая вычисляет произведение членов последовательности N натуральных чисел, кратных 5. Программа получает на вход целые числа, количество введеных чисел неизвестно, последовательность заканчивается числом N.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4.
Ответы (1)