Задать вопрос

Составить программу в Паскале Даны действительные положительные числа x, y, z. выяснить существует ли треугольник с данными сторонами

+2
Ответы (1)
  1. 9 мая, 05:54
    0
    program triangle;

    var x, y, z: real;

    begin

    writeln ('Введите длину 3 сторон треугольника через пробел');

    readln (x, y, z);

    if ((x+y<=z) or (x+z<=y) or (y+z<=x)) then

    writeln ('С указанными сторонами треугольник существовать не может')

    else

    writeln ('Можно построить треугольник с указанными сторонами')

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу в Паскале Даны действительные положительные числа x, y, z. выяснить существует ли треугольник с данными сторонами ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Даны действительные числа x, y, z Если все числа положительны, увеличить их значения в 2 раза; во всех отальных случаях отрицательные числа заменить их модулями, а положительные оставить без изменения. (Надо написать программу на паскале)
Ответы (1)
1. Даны вещественные положительные числа а, в, с, d. выяснить можно ли прямоугольник со сторонами а, b уместить внутри прямоугольника со сторонами с, d так, чтобы каждая из сторон одного прямоугольника былапараллельна или перпендикулярна каждой
Ответы (1)
Даны три отрезка со сторонами a, b, c. Выяснить можно ли построить треугольник с данными сторонами, если - да, то переменной y присвоить значение 1, иначе - 0.
Ответы (1)
даны действительные положительные числа a, d, c, b вычислить существует ли прчмоугольник с такими сторонами
Ответы (1)
Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон. Если существует, определите его типИмеются данные о количестве полных лет трех призеров спартакиады.
Ответы (1)