Задать вопрос

В результате выполнения следующего фрагмента программы переменные a и b: a: = (a+b) / 2; b: = (a-b) / 2; a:=a+b; b:=a-b; А. не изменились Б. поменялись местами В. поменялись местами и поменяли знак Г. поменяли знак на противоположный.

+2
Ответы (1)
  1. 13 марта, 14:53
    0
    Первое действие, записанное в программе влияет только на то, что сумма переменных а и b стала меньше в два раза, потому что их сумма поделилась на два. Все это присвоено переменной а.

    Вторым действием переменно b присвоена уменьшенная в два раза разница между первоначальными значениями переменных.

    Затем переменные восстанавливают свои значения.

    Значения их не изменятся, потому что если записать изменения переменной а в одном действии, то получится следующее:

    а = (a + b) / 2 + (a - b) / 2 = а/2 + b/2 + а/2 - b/2.

    Слагаемые с b сократятся и останется только а/2 + а/2, что равно а.

    ОТВЕТ: А.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В результате выполнения следующего фрагмента программы переменные a и b: a: = (a+b) / 2; b: = (a-b) / 2; a:=a+b; b:=a-b; А. не изменились ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1;
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
6) Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin s : = 0; for n:=4 to 13 do begin s : = s + 15; end; write (s) end.
Ответы (1)
Что выведется на экран в результате выполнения фрагмента программы: s:=0; FOR j:=1 TO 3 DO s:=s+2*j; write (' j=', j, ' s=', s) Что выведется на экран в результате выполнения фрагмента программы: p:=1; FOR k:=1 TO 5 DObegin p:=p*k; end;
Ответы (1)