Задать вопрос

Определите значение переменной a после выполнения фрагмента алгоритма: b:=0; a:=0; repeat a:=a+b; b:=b+2; until b=10; write (a);

+5
Ответы (1)
  1. 30 марта, 21:02
    0
    b:=0; a:=0 означают, что мы присваиваем начальное значение для "a" и "b" равное 0. Далее идет цикл повторения выражения a:=a+b; b:=b+2 до тех пор, пока значение "b" не станет равное 10, после этого выводится значение "а". Рассмотрим работу алгоритма по шагам. 1) a:=0+0 b:=0+2 2) Стоит отменить, что запоминается новое значение для каждой переменной, тоесть теперь a:=0+2 b:=2+2 3) a:=2+4 b:=4+2 4) a:=6+6 b:=6+2 5) a:=12+8 b:=8+2 (=10) 6) a:=20+10 Так как b достигло 10, цикл заканчивается и выводится значение а. а=30.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Определите значение переменной a после выполнения фрагмента алгоритма: b:=0; a:=0; repeat a:=a+b; b:=b+2; until b=10; write (a); ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1;
Ответы (1)
1) Определите значение переменных a и b после выполнения фрагмента алгоритма: a: = 86; b: = a mod 10 + 14; a: = а div 3 * 5; 2) Определите значение переменных a и b после выполнения фрагмента алгоритма: a: = 8673; b: = (a mod 100) * 10 + 14;
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X); 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
Определи значение переменной a после выполнения фрагмента алгоритма при a=3 и a=6. Ввод а если a>5 то a:=a+20 иначе a:=a*10 всё Ответ: при a=3 значение переменной a равно?, при a=6 значение переменной a равно?
Ответы (1)