Задать вопрос

Определить количество трехзначных натуральных чисел, сумма цифр которых равна заданному числу N

+4
Ответы (1)
  1. 12 декабря, 21:08
    0
    var n, i, col: integer; / /Заводим переменные для заданного числа, счётчика и количества.

    ned, ndes, ns: integer; / /Заводим переменные для единиц, десятков и сотен числа n.

    begin

    writeln ('Введите число n');

    readln (n);

    //Ниже разбиваем n на три цифры.

    ns : = n div 100;

    ndes : = (n div 10) mod 10;

    n = n mod 10;

    for i : = 100 to 999 do if ned + ndes + ns = i then col : = col + 1;

    writeln ('Количество таких чисел составляет ', col);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Определить количество трехзначных натуральных чисел, сумма цифр которых равна заданному числу N ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
2. Определить количество трёхзначных цифр, сумма цифр которого равна заданному числу N (в паскале, Цикл со счётчиком)
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4.
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма четных цифр и сумма нечетных цифр заданного числа. 2.
Ответы (1)
10. Автомат получает на вход два трехзначных числа. По этим числам строится новое число по следующим правилам. Вычисляются три числа - сумма старших разрядов заданных трехзначных чисел, сумма средних разрядов этих чисел, сумма младших разрядов.
Ответы (1)