Задать вопрос

Составить программу для нахождения суммы последовательности чисел произвольного диапазона (паскаль)

+2
Ответы (1)
  1. 13 декабря, 02:48
    0
    var

    x, y, i, s : integer; / / объявляем переменные целочисленного типа.

    begin

    writeln ('Введите число - начало диапазона: '); / / вывод строки на экран.

    readln (x); / / считываем значение введенное с клавиатуры.

    writeln ('Введите число - конец диапазона: '); / / вывод строки на экран.

    readln (y); / / считываем значение введенное с клавиатуры.

    for i : =x to y do / / начало цикла.

    s: = s + i; / / считаем сумму элементов в диапазоне.

    writeln ('Сумма последовательности чисел от ', x, ' до ', y,' равна ', s); / / вывод строки на экран.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу для нахождения суммы последовательности чисел произвольного диапазона (паскаль) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы