Задать вопрос

Найти сумму чисел кратных 5 от 1 до N.

+2
Ответы (1)
  1. 27 июля, 15:01
    0
    program zz1;

    var s, n, i:integer; / / задаем переменные целого типа

    begin

    write (' введите n '); / / вводим с клавиатуры число

    read (n);

    for i:=1 to n do / / организуем цикл, в котором переберем все числа от 1 до n

    begin

    if i mod 5 = 0 / / проверяем условие, если при делении на 5 число дает в остатке ноль, то

    then s: = s + i; / / прибавляем это число к сумме

    end;

    write (' сумма чисел кратных 5 от ', 1, ' до ', n, ' = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти сумму чисел кратных 5 от 1 до N. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)
1. найти сумму первых 10 чисел, кратных 7; 2. вывести на экран 11 первых чисел кратных 5; 3. составить программу рисования 18 прямоугольников синего цвета, координаты которых определяется случайным образом, а стороны равны а=140, b=40.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4.
Ответы (1)
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)