Задать вопрос

Вывести целое число и определить верно ли, что в его записи есть две одинаковые цифры. Например, 1234 - нет; 1224 - да. Обязательно должен присутствовать цикл с предусловием while do. Информатика. 8 класс. Паскаль ABC.

+1
Ответы (1)
  1. program zz1;

    var s, n, k, p:integer; / / задаем переменные целого типа

    begin

    write (' введите натуральное число ');

    read (n); / / вводим с клавиатуры число

    k:=n mod 10; / /получаем последнюю цифру

    s:=k; / / запоминаем ее

    n:=n div 10; / /отбрасываем ее

    while n > 0 do / / организуем цикл, пока в числе есть цифры

    begin

    k:=n mod 10; / /получаем последнюю цифру

    if k = s then p:=1; / / сравниваем с предыдущей

    s:=k; / / запоминаем ее

    n:=n div 10; / /отбрасываем ее

    end;

    if p = 1 / / проверяем, если нашлись две одинаковые

    then writeln (' Верно ') / / выводим один ответ

    else writeln (' Неверно '); / / иначе, выводим другой ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вывести целое число и определить верно ли, что в его записи есть две одинаковые цифры. Например, 1234 - нет; 1224 - да. Обязательно должен ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Дано число а и натуральное число n. Напечатать на экране а в степени n (Паскаль цикл с предусловием)
Ответы (1)
Ввести с клавиатуры 10 пар чисел, найти максимальное число в каждой паре и вывести его на экран. В работе использовать цикл с предусловием.
Ответы (1)
Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)