Задать вопрос

1. Массив А состоит из 10 чисел, выбранных случайным образом из интервала [-17; 15]. Подсчитать сумму отриц. значений массива.

+4
Ответы (1)
  1. 17 октября, 10:09
    0
    program zz1;

    const n = 10; / / задаем количество элементов в массиве

    var i, s:integer; / / задаем переменные целого типа

    A:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    A[i]:=random (33) - 17;

    for i:=1 to n do / / выводим полученный массив на экран

    write (A[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if A[i] < 0 then s:=s + A[i]; / / получаем сумму

    writeln (' сумма отрицательных элементов = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Массив А состоит из 10 чисел, выбранных случайным образом из интервала [-17; 15]. Подсчитать сумму отриц. значений массива. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Вывести массив 4*4 1 3 5 7 1 3 5 7 1 3 5 7 1 3 5 7 2) Массив 4*4 0010 0100 0000 1100 Подсчитать количество нулей и единиц 3) Случайным образом вывести массив 5*5 (50) A[I, j]: = random (50); Сумму элементов массива
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)
Массив на 20 элементов заполнить случайным образом в диапозоне от - 5 до 10. Найти произведение всех значений. Подсчитать количество значений больше 3. Массив вывести в строку
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)