Задать вопрос
14 июня, 20:13

Даны две строки: S и S0. Проверить, содержится ли строка S в строке S0. Если да, то вывести "ДА", если не содержится вывести "НЕТ"

+5
Ответы (1)
  1. 14 июня, 22:39
    0
    program zz1;

    var s, s0:string; / / задаем переменные строкового типа

    k:integer; / / задаем переменную целого типа

    begin

    write (' введите первую строку ');

    readln (s); / / вводим с клавиатуры заданную строку

    write (' введите вторую строку ');

    read (s0); / / вводим с клавиатуры вторую заданную строку

    k:=pos (s, s0); / / определяем позицию вхождения одной строки в другую строку

    if k = 0 / / проверяем, если вхождения нет, то

    then write (' НЕТ ') / / выводим один ответ

    else write (' ДА '); / / иначе, выводим другой ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны две строки: S и S0. Проверить, содержится ли строка S в строке S0. Если да, то вывести "ДА", если не содержится вывести "НЕТ" ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дана исходная строка: "12". Ее обработали по следующему алгоритму: в конец строки дописали ее зеркальную копию, а затем к цифрам стоящим на четных позициях считая слева направо, прибавили по 1. Получилась строка: "1322".
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
С+ + Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали.
Ответы (1)
Дан массив из тридцати элементов. Вывести индексы всех элементов, равных по значению а. Если таких элементов нет - вывести сообщение с текстом "No solution".
Ответы (1)