Задать вопрос
10 июня, 04:16

Составьте программу ввода элементов массива b[1 ... 6] с клавиатуры и вывода на экран элементов с положительными значениями.

+2
Ответы (1)
  1. 10 июня, 05:28
    0
    Обозначим массив из шести чисел буквой а. Порядковый номер элементов массива - буквой i, а значения элементов массива - a[i]. Будем использовать оператор цикла с параметром for. Тогда программа на языке программирования Pascal ABC может выглядеть так:

    program zadacha;

    uses crt;

    var a: array[1 ... 6] of integer; {Описание массива}

    i:integer;

    begin

    for i:=1 to 6 do begin

    writeln ('vvedite a[i]:');

    readln (a[i]); {Ввод элементов массива с клавиатуры во время выполнения программы}

    end;

    for i:=1 to 6 do

    if a[i]>0 {Поиск положительных элементов массива}

    then writeln ('a[i]=', a[i]); {Вывод положительных элементов массива на экран }

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу ввода элементов массива b[1 ... 6] с клавиатуры и вывода на экран элементов с положительными значениями. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
Составьте программу ввода с клавиатуры элементов массива a [1 ... 10] и вывода на экран элементов с чётными значениями и чётными индексами
Ответы (1)
1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями. 2. Составить программу ввода элементов массива A[1 ...
Ответы (1)
Составьте программу ввода с клавиатуры массива целых чисел a[1 ... 10] и вывода на экран элементов массива кратные 3.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)