Задать вопрос

Написать алгоритм и программу которая определяет сколько раз в данном слове встречается буквосочитание "пол"

+5
Ответы (1)
  1. 4 мая, 07:55
    0
    program zz1;

    var s:string; / / задаем переменную строкового типа

    i, k:integer; / / задаем переменные целого типа

    begin

    write (' введите строку ');

    read (s); / / вводим с клавиатуры заданную строку

    for i:=1 to length (s) - 2 do / / организуем цикл, в котором переберем все символы от первого до последнего минус два

    if copy (s, i, 3) = 'пол' then k:=k + 1; / / копируем по три буквы строки и сравниваем с "пол", если нашли, то считаем

    write (' в данном слове встречается буквосочетание "пол" = ', k, ' раз ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать алгоритм и программу которая определяет сколько раз в данном слове встречается буквосочитание "пол" ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Составить программу, которая определяет имеется ли в данном слове, часть, равная другому заданному слову. Например: слово 'код' входит в слово 'крокодил', но не входит в слово 'овод'. Оба слова должны запрашиваться с клавиатуры
Ответы (1)
Составить программу в паскале, которая определяет, сколько раз число 10 встречается среди элементов одномерного массива А (12), состоящего из целых чисел и заполненного с клавиатуры.
Ответы (1)
1. напишите программу которая в последовательности натуральных чисел определяет сумму чисел кратных семи и оканчивающихся на один количество не известно 2.
Ответы (1)