Задать вопрос

С клавиатуры вводится произвольное количество чисел N. Определите количество (К) и сумму (S) положительных чисел, оканчивающихся на 6. Запишите программу на любом языке программирования.

+3
Ответы (1)
  1. 14 декабря, 07:01
    0
    program zz1;

    var a, k, n, i, s:integer; / / задаем переменные целого типа

    begin

    write (' введите n '); / / вводим с клавиатуры количество чисел

    read (n);

    for i:=1 to n do / / организуем цикл

    begin

    read (a); / / вводим число

    if (a > 0) and (a mod 10 = 6) then begin k:=k + 1; s:=s + a; end; / / проверяем, если число положительное и последняя цифра у него 6, то считаем его и добавляем в сумму

    end;

    write (' количество положительных чисел оканчивающихся на 6 = ', k, ' их сумма = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «С клавиатуры вводится произвольное количество чисел N. Определите количество (К) и сумму (S) положительных чисел, оканчивающихся на 6. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
С клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0. Определить: 1) Количество четных чисел. 2) Сумму чисел, заканчивающихся на 5 и положительных Найти сумму чисел: 5+10+15+20+ ...+n
Ответы (1)
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)
Напечатать "столбиком": а) все целые числа от 20 до 35; б) квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b > (или равно) 10); в) третьи степени всех целых чисел от a до 50 (значение а вводится с клавиатуры; а (или равно) а).
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных чисел и ищет их сумму. число N вводится с клавиатуры.
Ответы (1)