Задать вопрос
18 июня, 15:14

Написать программы суммирования чисел от 1 до 100, используя все циклические конструкции (Repeat ... Until, While ... Do, For ... to). Найти среднее арифметическое этих чисел.

+3
Ответы (1)
  1. 18 июня, 18:08
    0
    Var sum, i:integer;

    sa:real;

    begin

    i:=0;

    sum:=0;

    for i:=1 to 100 do

    sum:=sum+i;

    writeln (sum);

    sa:=sum/i;

    writeln (sa:1:2);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программы суммирования чисел от 1 до 100, используя все циклические конструкции (Repeat ... Until, While ... Do, For ... to). ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать). Сделайте три варианта программы, используя операторы While, Repeat, For.
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1;
Ответы (1)
Дана непустая последовательность положительных целых чисел a1, a2, ... оканчивающаяся нулем. Получить a1, a1*a2, a1*a2*a3 ... 0 Решить, используя оператор until repeat либо while (паскаль)
Ответы (1)
Какие слова не используется в команде цикла с предусловием A) While B) repeat С) do D) Until
Ответы (1)