Задать вопрос
22 сентября, 16:36

Составить программу, которая формирует одномерный массив и выводит на экран все элементы, кратные 7.

+5
Ответы (1)
  1. 22 сентября, 19:17
    0
    program zz1;

    const n = 10; / / задаем количество чисел в массиве

    var i, s:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / организуем цикл, в котором введем с клавиатуры n заданных чисел в массив

    read (m[i]);

    for i:=1 to n do / / организуем цикл, в котором переберем все числа массива

    if m[i] mod 7 = 0 then write (m[i], ' '); / / проверяем если число делится на семь без остатка, то выводим его на экран в строку через пробел

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу, которая формирует одномерный массив и выводит на экран все элементы, кратные 7. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Написать программу, которая заполняет элементами массив по правилу: а (I) = (i^4/7i-2), выводит его элементы на экран с двумя знаками после запятой и затем выводит новый массив, в котором заменены на противоположные знаки элементов исходного массива.
Ответы (1)
Составьте программу, которая формирует массив из 20 случайных чисел, и выводит на экран вначале исходные, а затем преобразованные элементы массива таким образом, что производится перестановка 6 и 16 элементов массива
Ответы (1)
Составьте программу, которая формирует массив из 20 случайных целых чисел, каждое из которых находится в диапазоне от - 15 до 15, и выводит на экран вначале исходные, а затем только отрицацельные элементы массива
Ответы (1)