Задать вопрос
16 марта, 17:13

Среди двузначных чисел найти те, сумма квадратов цифр которых делится на13

+3
Ответы (1)
  1. 16 марта, 19:38
    0
    program zz1;

    var a, b, s, i:integer; / / задаем переменные целого типа

    begin

    for i:=10 to 99 do / / перебираем все двухзначные числа в цикле

    begin

    a: = i div 10; / / находим первую цифру двухзначного числа

    b: = i mod 10; / / находим вторую цифру двухзначного числа

    s:=sqr (a) + sqr (b); / / высчитываем сумму квадратов цифр двухзначного числа

    if s mod 13 = 0 / / проверяем на делимость полученной суммы на число 13

    then write (i, ' '); / / выводим ответ в строку через пробел

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Среди двузначных чисел найти те, сумма квадратов цифр которых делится на13 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1) Составить программу нахождения суммы квадратов чисел от 25 до 125. 2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма четных цифр и сумма нечетных цифр заданного числа. 2.
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
Ввести одно число, указывающие количество вводимых двузначных чисел. Из введенных двузначных чисел найти количество четных.
Ответы (1)