Задать вопрос

Составьте программу, которая преобразует введенное с клавиатуры дробное число в денежный формат. Например, число 12,348 должно быть преобразовано к виду 12 руб. 35 коп.

+3
Ответы (1)
  1. 17 марта, 08:59
    0
    Var i:integer; j, n:real;

    begin

    write ('Введите число: '); readln (n);

    i:=trunc (n);

    j:=round (frac (n) * 100);

    write (i,' руб. ', j, ' коп.');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу, которая преобразует введенное с клавиатуры дробное число в денежный формат. Например, число 12,348 должно быть ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая определяет, верно ли, что введённое число - - трёхзначное. Входные данные: Входная строка содержит единственное натуральное число.
Ответы (1)
Написать программу, которая проверяет, сколько раз введенное с клавиатуры число встречается в заданном массиве
Ответы (1)
Написать программу, которая проверяет, делятся ли на 3 (2,4) целое число, введенное с клавиатуры
Ответы (1)
Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.
Ответы (1)