Задать вопрос

Напишите программу которая в последовательности натуральных чисел определяет количество чисел меньше 500 и кратных 3. Програма получает на вход количетво чисел, а затем сами числа. Введеные числа не привышают 30000

+5
Ответы (1)
  1. 26 июля, 01:13
    0
    var a: array[1 ... 100] of integer;

    n, col, tmp: integer;

    begin

    writeln ('Введите количество чисел');

    readln (n);

    writeln ('Заполните массив с клавиатуры');

    for i : = 1 to n do begin

    readln (tmp);

    if tmp < = 30000 then a[i] : = tmp else writeln ('Введённое число больше 30000!');

    end;

    writeln ('Подсчитываем количество искомых чисел');

    for i : = 1 to n do if (a[i] < = 500) and (a[i] mod 3 = 0) then col : = col + 1;

    writeln ('Количество чисел, которые меньше 500 и кратны 3 ', col);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу которая в последовательности натуральных чисел определяет количество чисел меньше 500 и кратных 3. Програма получает на ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет максимальное, оканчивающееся на 1. Программа получает на вход кол-во чисел в последовательности, а затем сами числа.
Ответы (1)
1. напишите программу, которая для последовательности натуральных чисел определяет их сумму. Программа получает на вход количество чисел в последовательности и сами числа 2. Измените программу так, чтобы определялось произведение чисел. 3.
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)
Напишите программу в паскале, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)